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Total Agility - Error: "The Document Data is Null. Failed to store binary content to KTA using StoreBinaryChunk API"

When KIC tries to import an email and fails with the following error: The Document Data is Null. Failed to store binary content to KTA using StoreBinaryChunk API

Applies to Versions: 11.x

ISSUE
The following message is displayed in Message Connector monitor and no emails/files are imported:

The document data is null. Failed to store binary content to KTA using StoreBinaryChunk API

CAUSE
One known cause is attempting to upload larger documents from an Integration Server to the Cloud

There is a parameter in the Agility.Server.Core.WorkerService.exe config file on the Integration Server called ReadBinaryContentSizeInKB,

The OOTB value is 25600, however, the optimal value for an Integration Server connecting to a Cloud instance is 1024 (1MB)

SOLUTION
Update the ReadBinaryContentSizeInKB parameter in the Agility.Server.Core.WorkerService.exe config file on the Integration Server to use the value 1024

Restart the services on the Integration Server